FAQ: Using version 7 plug-ins

Will my plug-in work with version 8?

Short Answer

Most version 7 plug-ins will work with version 8.

Long Answer

There is an issue with final_step being used in a plug-in. It is a broad problem that can arise when final_step is used in a plug-in, and relies on specific names or layout in the profile. Because final_step can contain arbitrary code, and can access or modify anything, it bypasses the structured layout of the rest of the profile, and is therefore potentially version specific, and cannot be automatically converted. While any standard v7 plug-in will work with v8, plug-ins that use final_step may not work, if they access structures which have been removed or renamed in version 8. This sort of plug-in will have to be manually modified to make it v8 compatible.