FAQ: Winsock 2

When I run Sawmill on Windows, I get an error: "A required DLL is missing: WS2_32.DLL." What's going on?

Short Answer

You need Winsock 2.

Long Answer
To run on Windows 95, and some early versions of Windows 98, Sawmill requires Winsock2, a networking component available for free from Microsoft. You can download Winsock2 from here.

Winsock2 is already part of Windows 98 (newer versions), Windows NT 4.0, and Windows 2000, so you do not need to download this component unless you are using Windows 95 or an old version of Windows 98.